Homeswift
swift and AFV
Version 0.9.3 is AFV compliant

We have a first version of swift with AFV integrated. This is released as alpha version, as we still expect some issues. Your feedback is welcome.

IMPORTANT: The 0.9.3 versions do NOT work with the old VATSIM voice servers, only with AFV.

What is AFV?

Audio for VATSIM (AFV) is the new voice codec for VATSIM, more information can be found here and here.

VATSIM will be offline for scheduled maintenance for 24 hours, from 2019-10-13 2000z until 2019-10-14 2000z. During that time, the network will migrate over to the new codec, and the old codec will stop working. If you want to continue using swift 0.9.2 beta after that time, you will need to install an extra piece of software: the AFV standalone client, which works on Windows only.

Summary

swift versionstatusworks with old codec?works with new codec?
0.9.2beta yes need AFV standalone client
0.9.3alpha no yes (integrated in swift)

WASAPI audio plugin (Windows)

The WASAPI plugins in Windows seem to be buggy. We recommend to remove them, just using the Windows plugin should be fine. Just move them to another directory (outside swift), so you can copy them back if needed.

  • Go into your swift installation bin path (e.g. C:\Program Files\swift-0.9.3-64bit\bin).
  • Change to subfolder audio
  • Find dlls containing wasapi.
  • Move them to a backup directory outside swift

Voice room connect error (swift 0.9.2)

If you use 0.9.2 or earlier, you might see that error. It happens because VATSIM now uses some invalid voice room URLs.
Solution: use 0.9.3. if you dare, but read the above.

Written by kbasan on Oct 11 2019, 10:31 PM.
swift developer
Projects
Subscribers
rdiehl

Event Timeline

I am installing the alpha 0.9.3 into a linux OS and for some reason the alpha 0.9.3 isn't allowing me to run the binaries after installation.

To confirm my permissions and ownership were not to blame I installed the beta 0.9.2 and was able to run all binaries as usual. Second attempt at installing 0.9.3 resulted with the same inability to run binaries.

Are there any additional installation steps required with alpha installations that are not needed with open betas?

Russell Diehl

Please use Discord for support questions: https://discord.gg/PtXNNkV