Page MenuHomeswift

System Requirements
Updated 78 Days AgoPublic

Operating System Requirements

swift applications are running on all relevant operation systems. Find below the specific support and requirements for each platform.

Windows

  • Microsoft Windows 7, 8, 8.1, or 10 in 32 or 64 bit.
  • 200 MB free disk space

Mac OS

  • MacOS 10.10 or higher
  • Only 64 bit
  • 200 MB free disk space

Linux

  • Only 64 bit
  • 200 MB free disk space

swift is built on Ubuntu 16.04 LTS. Therefore it should run on any modern Linux distributions that has the following minimum package versions installed

  • glibc 2.23 or higher
  • glibcxx 2.3.22 or higher
  • libportaudio2
  • libspeexdsp
  • OpenSSL 1.0. OpenSSL 1.1 is currently not supported, so make sure that the dynamic linker will find and resolve version 1.0 at runtime.

Simulator Requirements

swift supports the following simulators:

  • Microsoft Flight Simulator 2004 (experimental)
  • Microsoft Flight Simulator X with Acceleration or Service Pack 2
  • Microsoft Flight Simulator Steam Edition
  • Lockheed Martin Prepar3D v1 - v4 (including minor versions)
  • X-Plane 9 (untested)
  • X-Plane 10
  • X-Plane 11

Next Steps

Continue by:

Download installer 32 bit or 64 bit installer?

Last Author
rrossgotterer
Last Edited
Aug 28 2018, 11:24 AM

Event Timeline

rrossgotterer created this document.Aug 28 2018, 11:09 AM
rrossgotterer edited the content of this document. (Show Details)
rrossgotterer edited the content of this document. (Show Details)Aug 28 2018, 11:15 AM
rrossgotterer edited the content of this document. (Show Details)Aug 28 2018, 11:24 AM
rrossgotterer added a project: Restricted Project.